Creates an array of new model line elements.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- geometryCurveArray
- Type: Autodesk.Revit.DBCurveArray
An array containing the internal geometry curves for model lines.
- sketchPlane
- Type: Autodesk.Revit.DBSketchPlane
Return Value
If successful an array of new model line elements. Otherwise a null reference (Nothing in Visual Basic).Remarks
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Thrown when curve is not in the plane |