NewModelCurveArray Method


Item Factory Base New Model Curve Array Method

Creates an array of new model line elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ModelCurveArray NewModelCurveArray(
	CurveArray geometryCurveArray,
	SketchPlane sketchPlane
)

Parameters

geometryCurveArray CurveArray
An array containing the internal geometry curves for model lines.
sketchPlane SketchPlane

Return Value

ModelCurveArray
If successful an array of new model line elements. Otherwise .
Exceptions
Exception Condition
ArgumentException Thrown when curve is not in the plane
See Also