PassesFilter Method (Element)


Applies the filter to a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public bool PassesFilter(
	Element element
)
Visual Basic
Public Function PassesFilter ( _
	element As Element _
) As Boolean
Visual C++
public:
bool PassesFilter(
	Element^ element
)

Parameters

element
Type: Autodesk.Revit.DBElement
The element.

Return Value

True if the element is accepted by the filter. False if the element is rejected.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also