SetSegmentAs180DegreeBend Method (Int32, ElementId, Boolean)


Indicate that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be driven by radiusParam.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetSegmentAs180DegreeBend(
	int iSegment,
	ElementId paramId,
	bool measureToOutsideOfBend
)
Visual Basic
Public Sub SetSegmentAs180DegreeBend ( _
	iSegment As Integer, _
	paramId As ElementId, _
	measureToOutsideOfBend As Boolean _
)
Visual C++
public:
void SetSegmentAs180DegreeBend(
	int iSegment, 
	ElementId^ paramId, 
	bool measureToOutsideOfBend
)

Parameters

iSegment
Type: SystemInt32
Index of the segment (0 to NumberOfSegments - 1).
paramId
Type: Autodesk.Revit.DBElementId
Id of a parameter to drive the radius. To obtain the id of a shared parameter, call RebarShape.GetElementIdForExternalDefinition().
measureToOutsideOfBend
Type: SystemBoolean
Choose between two possibilities for the references of the radius dimension. If true, measure to the exterior face of the bar. If false, measure to the interior face.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException iSegment is not between 0 and NumberOfSegments. -or- paramId is not the id of a shared parameter in the current document, or its unit type is not UT_Reinforcement_Length or UT_Angle.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also