SetSegmentAs180DegreeBend Method (Int32, ElementId, Boolean)


Rebar Shape Definition By Segments Set Segment As 180Degree Bend(Int 32, Element Id, Boolean) Method

Indicate that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be driven by radiusParam.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetSegmentAs180DegreeBend(
	int iSegment,
	ElementId paramId,
	bool measureToOutsideOfBend
)

Parameters

iSegment Int32
Index of the segment (0 to NumberOfSegments - 1).
paramId ElementId
Id of a parameter to drive the radius. To obtain the id of a shared parameter, call RebarShape.GetElementIdForExternalDefinition().
measureToOutsideOfBend Boolean
Choose between two possibilities for the references of the radius dimension. If true, measure to the exterior face of the bar. If false, measure to the interior face.
Exceptions
Exception Condition
ArgumentException iSegment is not between 0 and NumberOfSegments. -or- paramId is not the id of a shared parameter in the current document, or its unit type is not Reinforcement_Length, Angle or Number.
ArgumentNullException A non-optional argument was null
See Also