SubcategoryId Property


Build-in or user defined subcategory of Structural Load Cases (OST_LoadCases) category.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public ElementId SubcategoryId { get; set; }
Visual Basic
Public Property SubcategoryId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ SubcategoryId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Remarks

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException When setting this property: the subcategoryId does not refer to predefined nor user defined load case category element.
Autodesk.Revit.ExceptionsArgumentNullException When setting this property: A non-optional argument was null

See Also