AlmostEqual Method


Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2021

Syntax

C#
public bool AlmostEqual(
	Transform2D right
)
Visual Basic
Public Function AlmostEqual ( _
	right As Transform2D _
) As Boolean
Visual C++
public:
bool AlmostEqual(
	Transform2D^ right
)

Parameters

right
Type: Autodesk.Revit.DBTransform2D
The transformation to compare with this transformation.

Return Value

True if the two transformations are equal, false otherwise.

Remarks

The tolerance is applied memberwise for comparison.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also