Constructs a new instance of a filter to match elements which are owned by a particular view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- viewId
- Type: Autodesk.Revit.DBElementId
The view id to match. Pass invalid element id to create a filter that will pass non-view-specific elements.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |