ElementOwnerViewFilter Constructor (ElementId)


Element Owner View Filter(Element Id) Constructor

Constructs a new instance of a filter to match elements which are owned by a particular view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementOwnerViewFilter(
	ElementId viewId
)

Parameters

viewId ElementId
The view id to match. Pass invalid element id to create a filter that will pass non-view-specific elements.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also