NewCurtainSystem Method


Creates a new CurtainSystem element from a set of faces.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurtainSystem NewCurtainSystem(
	FaceArray faces,
	CurtainSystemType curtainSystemType
)
Visual Basic
Public Function NewCurtainSystem ( _
	faces As FaceArray, _
	curtainSystemType As CurtainSystemType _
) As CurtainSystem
Visual C++
public:
CurtainSystem^ NewCurtainSystem(
	FaceArray^ faces, 
	CurtainSystemType^ curtainSystemType
)

Parameters

faces
Type: Autodesk.Revit.DBFaceArray
The faces new CurtainSystem will be created on.
curtainSystemType
Type: Autodesk.Revit.DBCurtainSystemType
The Type of CurtainSystem to be created.

Return Value

The CurtainSystem created will be returned when the operation succeeds.

Remarks

The input faces will be copied during the operations so that they can be any faces.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown in following cases: The input argument faces or curtainSystemType is a null reference (Nothing in Visual Basic). The size of faces is zero.
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when the CurtainSystem cannot be created or regenerate fails.
Autodesk.Revit.ExceptionsArgumentExceptionThrown if the curtain system type does not exist in the given document.

See Also