Document New |
Creates a new CurtainSystem element from a set of faces.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public CurtainSystem NewCurtainSystem(
FaceArray faces,
CurtainSystemType curtainSystemType
)
Parameters
- faces FaceArray
- The faces new CurtainSystem will be created on.
- curtainSystemType CurtainSystemType
- The Type of CurtainSystem to be created.
Return Value
CurtainSystemThe CurtainSystem created will be returned when the operation succeeds.

Exception | Condition |
---|---|
ArgumentNullException | Thrown in following cases: The input argument faces or curtainSystemType is . The size of faces is zero. |
InvalidOperationException | Thrown when the CurtainSystem cannot be created or regenerate fails. |
ArgumentException | Thrown if the curtain system type does not exist in the given document. |

The input faces will be copied during the operations so that they can be any faces.