NewProjectTemplateDocument Method


New project template document

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Document NewProjectTemplateDocument(
	string templateFilename
)
Visual Basic
Public Overridable Function NewProjectTemplateDocument ( _
	templateFilename As String _
) As Document
Visual C++
public:
virtual Document^ NewProjectTemplateDocument(
	String^ templateFilename
)

Parameters

templateFilename
Type: SystemString
The template file name.

Remarks

This command corresponds to New->Project->Project Template command in the user-interface.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentExceptionIf 'templateFileName' is a null reference (Nothing in Visual Basic) or an empty string.
Autodesk.Revit.ExceptionsInvalidOperationExceptionIf the project template document cannot be created.

See Also