NewProjectTemplateDocument Method


Application New Project Template Document Method

New project template document

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public virtual Document NewProjectTemplateDocument(
	string templateFilename
)

Parameters

templateFilename String
The template file name.

Return Value

Document
Exceptions
Exception Condition
ArgumentException If 'templateFileName' is or an empty string.
InvalidOperationException If the project template document cannot be created.
Remarks
This command corresponds to New->Project->Project Template command in the user-interface.
See Also