Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- refPlane
- Type: Autodesk.Revit.DBPlane
The geometry of the new reference plane.
- options
- Type: Autodesk.Revit.DBDirectShapeReferenceOptions
The options that are used to configure the new reference plane.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | options cannot be used to add a reference object to this DirectShapeType. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |