AddReferencePlane Method (Plane, DirectShapeReferenceOptions)


Direct Shape Type Add Reference Plane(Plane, Direct Shape Reference Options) Method

Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddReferencePlane(
	Plane refPlane,
	DirectShapeReferenceOptions options
)

Parameters

refPlane Plane
The geometry of the new reference plane.
options DirectShapeReferenceOptions
The options that are used to configure the new reference plane.
Exceptions
Exception Condition
ArgumentException options cannot be used to add a reference object to this DirectShapeType.
ArgumentNullException A non-optional argument was null
See Also