ConnectToUpstreamNode Method


Connects to an upstream electrical analytical node.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public void ConnectToUpstreamNode(
	ElementId upstreamNodeId
)
Visual Basic
Public Sub ConnectToUpstreamNode ( _
	upstreamNodeId As ElementId _
)
Visual C++
public:
void ConnectToUpstreamNode(
	ElementId^ upstreamNodeId
)

Parameters

upstreamNodeId
Type: Autodesk.Revit.DBElementId
The upstream electrical analytical node id.

Remarks

If the area based load supplies from Node A, Node A is the upstream node of the area based load, and the area based load is the downstream node of node A.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The id is not an electrical analytical node id. -or- The area based load can not connect to the upstream electrical analytical node.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also