ConnectToUpstreamNode Method


Area Based Load Data Connect To Upstream Node Method

Connects to an upstream electrical analytical node.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void ConnectToUpstreamNode(
	ElementId upstreamNodeId
)

Parameters

upstreamNodeId ElementId
The upstream electrical analytical node id.
Exceptions
Exception Condition
ArgumentException The id is not an electrical analytical node id. -or- The area based load can not connect to the upstream electrical analytical node.
ArgumentNullException A non-optional argument was null
Remarks
If the area based load supplies from Node A, Node A is the upstream node of the area based load, and the area based load is the downstream node of node A.
See Also