CreateSharedParameterApplicableRule Method


Creates a filter rule that tests elements for support of a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static FilterRule CreateSharedParameterApplicableRule(
	string parameterName
)
Visual Basic
Public Shared Function CreateSharedParameterApplicableRule ( _
	parameterName As String _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateSharedParameterApplicableRule(
	String^ parameterName
)

Parameters

parameterName
Type: SystemString
The name of the parameter that elements must support to satisfy this rule.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also