CreateSharedParameterApplicableRule Method


Parameter Filter Rule Factory Create Shared Parameter Applicable Rule Method

Creates a filter rule that tests elements for support of a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static FilterRule CreateSharedParameterApplicableRule(
	string parameterName
)

Parameters

parameterName String
The name of the parameter that elements must support to satisfy this rule.

Return Value

FilterRule
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also