GetTileFamilyInstance Method


Get a reference to a tile element associated with a given seed node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstance GetTileFamilyInstance(
	GridNode gridNode,
	int tileIndex
)
Visual Basic
Public Function GetTileFamilyInstance ( _
	gridNode As GridNode, _
	tileIndex As Integer _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ GetTileFamilyInstance(
	GridNode gridNode, 
	int tileIndex
)

Parameters

gridNode
Type: Autodesk.Revit.DBGridNode
tileIndex
Type: SystemInt32

Return Value

A FamilyInstance object. Returns a null reference (Nothing in Visual Basic) if the ObjectType property is not a FamilySymbol. Returns a null reference (Nothing in Visual Basic) if the grid node is not a "seed node", or if the tile is omitted due to boundary conditions.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException Thrown if the grid node is outside of the range specified by NumberOfUGridlines and NumberOfVGridlines, or if tileIndex is outside the range [0, TilesPerSeedNode-1].

See Also