GetTileFamilyInstance Method


Divided Surface Get Tile Family Instance Method

Get a reference to a tile element associated with a given seed node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FamilyInstance GetTileFamilyInstance(
	GridNode gridNode,
	int tileIndex
)

Parameters

gridNode GridNode
tileIndex Int32

Return Value

FamilyInstance
A FamilyInstance object. Returns if the ObjectType property is not a FamilySymbol. Returns if the grid node is not a "seed node", or if the tile is omitted due to boundary conditions.
Exceptions
Exception Condition
ArgumentOutOfRangeException Thrown if the grid node is outside of the range specified by NumberOfUGridlines and NumberOfVGridlines, or if tileIndex is outside the range [0, TilesPerSeedNode-1].
See Also