Creates a new closed curve loop by thickening the input open curve loop with respect to a given plane.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- curveLoop
- Type: Autodesk.Revit.DBCurveLoop
The input curve loop.
- thickness
- Type: SystemDouble
The distance between the offset curves created on either side of the input curve.
- normal
- Type: Autodesk.Revit.DBXYZ
The normal vector to the plane used for thickening.
Return Value
The new curve loop.Remarks
The new loop will be created via offsets of the input curve loop (in the plane of the normal vector) with the endpoints connected with lines.The original curve loop will be at the center of the new loop.
If the curve loop contains curves such as elliptical segments or splines, it is possible the offset creation will fail if Revit will not be able to trim contiguous curves to meet one another. If the offset is successful, offsets of those curve types will be created as HermiteSplines.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The input thickness is too short for a curve. -or- the curve loop is not marked as open. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | Throws if the input curve could not be thickened. |