CreateViaThicken Method (CurveLoop, Double, XYZ)


Curve Loop Create Via Thicken(Curve Loop, Double, XYZ) Method

Creates a new closed curve loop by thickening the input open curve loop with respect to a given plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static CurveLoop CreateViaThicken(
	CurveLoop curveLoop,
	double thickness,
	XYZ normal
)

Parameters

curveLoop CurveLoop
The input curve loop.
thickness Double
The distance between the offset curves created on either side of the input curve.
normal XYZ
The normal vector to the plane used for thickening.

Return Value

CurveLoop
The new curve loop.
Exceptions
Exception Condition
ArgumentException The input thickness is too short for a curve. -or- the curve loop is not marked as open.
ArgumentNullException A non-optional argument was null
InvalidOperationException Throws if the input curve could not be thickened.
Remarks
The new loop will be created via offsets of the input curve loop (in the plane of the normal vector) with the endpoints connected with lines.The original curve loop will be at the center of the new loop.

If the curve loop contains curves such as elliptical segments or splines, it is possible the offset creation will fail if Revit will not be able to trim contiguous curves to meet one another. If the offset is successful, offsets of those curve types will be created as HermiteSplines.

See Also