ChangeHostReference Method (Reference, Edge)


Changes the connector host reference to a new planar face and a new edge loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public void ChangeHostReference(
	Reference planarFace,
	Edge edge
)
Visual Basic
Public Sub ChangeHostReference ( _
	planarFace As Reference, _
	edge As Edge _
)
Visual C++
public:
void ChangeHostReference(
	Reference^ planarFace, 
	Edge^ edge
)

Parameters

planarFace
Type: Autodesk.Revit.DBReference
The planar face to place the connector on.
edge
Type: Autodesk.Revit.DBEdge
One of the edges in the edge loop that defines the new connector location on the planar face.

Remarks

The connector referenced by an edge loop has the fixed origin as defined by the edge loop.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The face is not a planar face. -or- The edge is not on the planar face.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also