ChangeHostReference Method (Reference, Edge)


Connector Element Change Host Reference(Reference, Edge) Method

Changes the connector host reference to a new planar face and a new edge loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void ChangeHostReference(
	Reference planarFace,
	Edge edge
)

Parameters

planarFace Reference
The planar face to place the connector on.
edge Edge
One of the edges in the edge loop that defines the new connector location on the planar face.
Exceptions
Exception Condition
ArgumentException The face is not a planar face. -or- The edge is not on the planar face.
ArgumentNullException A non-optional argument was null
Remarks
The connector referenced by an edge loop has the fixed origin as defined by the edge loop.
See Also