ChangeService Method


Changes the service of the selection of fabrication parts.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018.2

Syntax

C#
public FabricationNetworkChangeServiceResult ChangeService(
	ISet<ElementId> selection,
	int serviceId,
	int paletteId
)
Visual Basic
Public Function ChangeService ( _
	selection As ISet(Of ElementId), _
	serviceId As Integer, _
	paletteId As Integer _
) As FabricationNetworkChangeServiceResult
Visual C++
public:
FabricationNetworkChangeServiceResult ChangeService(
	ISet<ElementId^>^ selection, 
	int serviceId, 
	int paletteId
)

Parameters

selection
Type: System.Collections.GenericISetElementId
The set of element identifiers of fabrication parts to change the service for.
serviceId
Type: SystemInt32
The identifier of the fabrication service.
paletteId
Type: SystemInt32
The identifier of the fabrication palette.

Remarks

After this method has been invoked, call:

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The selection contains invalid elements to change.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException No fabrication configuration is loaded.

See Also