ChangeService Method


Fabrication Network Change Service Change Service(ISet Element Id , Int 32, Int 32) Method

Changes the service of the selection of fabrication parts.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FabricationNetworkChangeServiceResult ChangeService(
	ISet<ElementId> selection,
	int serviceId,
	int paletteId
)

Parameters

selection ISet ElementId
The set of element identifiers of fabrication parts to change the service for.
serviceId Int32
The identifier of the fabrication service.
paletteId Int32
The identifier of the fabrication palette.

Return Value

FabricationNetworkChangeServiceResult
Exceptions
Exception Condition
ArgumentException The selection contains invalid elements to change.
ArgumentNullException A non-optional argument was null
InvalidOperationException No fabrication configuration is loaded.
Remarks
After this method has been invoked, call:
See Also