AsDouble Method


Provides access to the double precision number of the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Nullable<double> AsDouble(
	FamilyParameter familyParameter
)
Visual Basic
Public Function AsDouble ( _
	familyParameter As FamilyParameter _
) As Nullable(Of Double)
Visual C++
public:
Nullable<double> AsDouble(
	FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DBFamilyParameter

Return Value

The double value contained in the parameter. Returns a null reference (Nothing in Visual Basic) if the storage type of the input argument is not double type or this parameter has no value.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when the input argument-"familyParameter"-is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentException Thrown if the input argument-"familyParameter"-is invalid,

See Also