Identifies if the input element is visible for the temporary view mode for this view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- mode
- Type: Autodesk.Revit.DBTemporaryViewMode
The temporary view mode. Only TemporaryHideIsolate and AnalyticalModel modes are supported by this option. Other modes will result in an exception.
- id
- Type: Autodesk.Revit.DBElementId
The element id.
Return Value
True if the element is visible, false if the element is hidden in the view mode.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | This view mode is not supported for checking element visibility. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |