View Is |
Identifies if the input element is visible for the temporary view mode for this view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public bool IsElementVisibleInTemporaryViewMode(
TemporaryViewMode mode,
ElementId id
)
Parameters
- mode TemporaryViewMode
- The temporary view mode. Only TemporaryHideIsolate and AnalyticalModel modes are supported by this option. Other modes will result in an exception.
- id ElementId
- The element id.
Return Value
BooleanTrue if the element is visible, false if the element is hidden in the view mode.

Exception | Condition |
---|---|
ArgumentException | This view mode is not supported for checking element visibility. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |