SetStructuralAsset Method


Sets a copy of the given StucturalAsset to be used in the PropertySetElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public void SetStructuralAsset(
	StructuralAsset structuralAsset
)
Visual Basic
Public Sub SetStructuralAsset ( _
	structuralAsset As StructuralAsset _
)
Visual C++
public:
void SetStructuralAsset(
	StructuralAsset^ structuralAsset
)

Parameters

structuralAsset
Type: Autodesk.Revit.DBStructuralAsset

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException Thrown when the name of the asset is empty, contains prohibited characters, or is not unique
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also