SetStructuralAsset Method


Property Set Element Set Structural Asset Method

Sets a copy of the given StucturalAsset to be used in the PropertySetElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetStructuralAsset(
	StructuralAsset structuralAsset
)

Parameters

structuralAsset StructuralAsset
Exceptions
Exception Condition
ArgumentException Thrown when the name of the asset is empty, contains prohibited characters, or is not unique
ArgumentNullException A non-optional argument was null
See Also