AllowedValues Property


The allowable range of values to be parsed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public AllowedValues AllowedValues { get; set; }
Visual Basic
Public Property AllowedValues As AllowedValues
	Get
	Set
Visual C++
public:
property AllowedValues AllowedValues {
	AllowedValues get ();
	void set (AllowedValues value);
}

Field Value

The allowable range of values. The default is All.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also