Provides access to the individual failure messages if a given severity currently posted in the document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- severity
- Type: Autodesk.Revit.DBFailureSeverity
The failure severity for which failure messages are requested. If the requested severity is None, an empty collection is returned.
Return Value
Accessors to the individual failure messages of a given severity posted in the document.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.ExceptionsInvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). |