Failures |
Provides access to the individual failure messages if a given severity currently posted in the document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- severity FailureSeverity
- The failure severity for which failure messages are requested. If the requested severity is None, an empty collection is returned.
Return Value
IList FailureMessageAccessorAccessors to the individual failure messages of a given severity posted in the document.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). |