Rotates a connected fabrication tap by the specified angles about the primary and secondary axis.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Release
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- tap
- Type: Autodesk.Revit.DBFabricationPart
The connected fabrication part tap to rotate.
- primaryAxisRotateBy
- Type: SystemDouble
The primary axis rotation angle in radians to rotate by.
- secondaryAxisRotateBy
- Type: SystemDouble
The secondary axis rotation angle in radians to rotate by.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Is not connected as a fabrication part tap. -or- tap cannot be rotated about the primary axis by the specified angle: primaryAxisRotateBy -or- tap cannot be rotated about the secondary axis by the specified angle: secondaryAxisRotateBy |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |