RotateConnectedTap Method


Fabrication Part Rotate Connected Tap Method

Rotates a connected fabrication tap by the specified angles about the primary and secondary axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void RotateConnectedTap(
	Document document,
	FabricationPart tap,
	double primaryAxisRotateBy,
	double secondaryAxisRotateBy
)

Parameters

document Document
The document.
tap FabricationPart
The connected fabrication part tap to rotate.
primaryAxisRotateBy Double
The primary axis rotation angle in radians to rotate by.
secondaryAxisRotateBy Double
The secondary axis rotation angle in radians to rotate by.
Exceptions
Exception Condition
ArgumentException Is not connected as a fabrication part tap. -or- tap cannot be rotated about the primary axis by the specified angle: primaryAxisRotateBy -or- tap cannot be rotated about the secondary axis by the specified angle: secondaryAxisRotateBy
ArgumentNullException A non-optional argument was null
See Also