IsWorksetVisible Method


Indicates whether the workset is visible by default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public bool IsWorksetVisible(
	WorksetId worksetId
)
Visual Basic
Public Function IsWorksetVisible ( _
	worksetId As WorksetId _
) As Boolean
Visual C++
public:
bool IsWorksetVisible(
	WorksetId^ worksetId
)

Parameters

worksetId
Type: Autodesk.Revit.DBWorksetId
Id of the workset.

Return Value

Whether the workset is visible by default.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException There is no workset with this Id in the document.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException WorksetDefaultVisibilitySettings is not applicable to family documents.

See Also