AddSpace Method


Adds an IfcSpace handle to associate with the IfcProduct in this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public void AddSpace(
	IFCAnyHandle spaceHandle,
	IFCLevelInfo pLevelInfo,
	IFCExtrusionCreationData pParams,
	bool relateToLevel
)
Visual Basic
Public Sub AddSpace ( _
	spaceHandle As IFCAnyHandle, _
	pLevelInfo As IFCLevelInfo, _
	pParams As IFCExtrusionCreationData, _
	relateToLevel As Boolean _
)
Visual C++
public:
void AddSpace(
	IFCAnyHandle^ spaceHandle, 
	IFCLevelInfo^ pLevelInfo, 
	IFCExtrusionCreationData^ pParams, 
	bool relateToLevel
)

Parameters

spaceHandle
Type: Autodesk.Revit.DB.IFCIFCAnyHandle
The IfcSpace handle.
pLevelInfo
Type: Autodesk.Revit.DB.IFCIFCLevelInfo
Information on the associated level.
pParams
Type: Autodesk.Revit.DB.IFCIFCExtrusionCreationData
The extrusion creation data associated with the given space. Optional, can be a null reference (Nothing in Visual Basic).
relateToLevel
Type: SystemBoolean
True to relate the space to the level, false otherwise.

Remarks

If the IFCLevelInfo is not provided, and relateToLevel to true, the handle will be associated to the building handle.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also