IFCProduct |
Adds an IfcSpace handle to associate with the IfcProduct in this wrapper.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)

public void AddSpace(
IFCAnyHandle spaceHandle,
IFCLevelInfo pLevelInfo,
IFCExtrusionCreationData pParams,
bool relateToLevel
)
Parameters
- spaceHandle IFCAnyHandle
- The IfcSpace handle.
- pLevelInfo IFCLevelInfo
- Information on the associated level.
- pParams IFCExtrusionCreationData
- The extrusion creation data associated with the given space. Optional, can be .
- relateToLevel Boolean
- True to relate the space to the level, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

If the IFCLevelInfo is not provided, and relateToLevel to true, the handle will be associated to the building handle.