SweepProfile Class


Represents a profile for sweep or swept blend elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class SweepProfile : APIObject
Visual Basic
Public Class SweepProfile _
	Inherits APIObject
Visual C++
public ref class SweepProfile : public APIObject

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBSweepProfile
      Autodesk.Revit.DBCurveLoopsProfile
      Autodesk.Revit.DBFamilySymbolProfile

See Also