Sweep |
Represents a profile for sweep or swept blend elements.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB SweepProfile
Autodesk.Revit.DB CurveLoopsProfile
Autodesk.Revit.DB FamilySymbolProfile
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB SweepProfile
Autodesk.Revit.DB CurveLoopsProfile
Autodesk.Revit.DB FamilySymbolProfile
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The SweepProfile type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject ) |

Name | Description | |
---|---|---|
![]() | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |