Sets the text and associated formatting of the text of in this text note with a given FormattedText object.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- formattedText
- Type: Autodesk.Revit.DBFormattedText
The FormattedText object containing the text and associated formatting of the text.
Examples

#region Autodesk.Revit.DB.FormattedText
public void FormatText(TextNote textNote)
{
// TextNote created with "New sample text"
FormattedText formatText = textNote.GetFormattedText();
// italicize "New"
TextRange range = new TextRange(0, 3);
formatText.SetItalicStatus(range, true);
// make "sample" bold
range = formatText.Find("sample", 0, false, true);
if (range.Length > 0)
formatText.SetBoldStatus(range, true);
// make "text" underlined
range = formatText.Find("text", 0, false, true);
if (range.Length > 0)
formatText.SetUnderlineStatus(range, true);
// make all text uppercase
formatText.SetAllCapsStatus(true);
textNote.SetFormattedText(formatText);
}
#endregion

#Region "Autodesk.Revit.DB.FormattedText"
Public Sub FormatText(textNote As TextNote)
' TextNote created with "New sample text"
Dim formatText__1 As FormattedText = textNote.GetFormattedText()
' italicize "New"
Dim range As New TextRange(0, 3)
formatText__1.SetItalicStatus(range, True)
' make "sample" bold
range = formatText__1.Find("sample", 0, False, True)
If range.Length > 0 Then
formatText__1.SetBoldStatus(range, True)
End If
' make "text" underlined
range = formatText__1.Find("text", 0, False, True)
If range.Length > 0 Then
formatText__1.SetUnderlineStatus(range, True)
End If
' make all text uppercase
formatText__1.SetAllCapsStatus(True)
textNote.SetFormattedText(formatText__1)
End Sub
#End Region
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |