Returns true if references are valid targets for handle, false otherwise.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- handle
- Type: Autodesk.Revit.DB.StructureRebarConstrainedHandle
Represents the constrainable rebar handle.
- targetsToConstrain
- Type: System.Collections.GenericIListReference
Represent the refernces to be checked as valid targets for handle.
Remarks
For a free form rebar valid targets are one or more references to faces of elements that can host rebar.
For a shape driven rebar this function will always return false. RebarConstraintsManager.GetConstraintCandidatesForHandle() can be used to obtain possible constraints.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | The RebarConstraintsManager does not manage a valid Rebar element. |