Rebar |
Returns true if references are valid targets for handle, false otherwise.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public bool AllowConstraintTargets(
RebarConstrainedHandle handle,
IList<Reference> targetsToConstrain
)
Parameters
- handle RebarConstrainedHandle
- Represents the constrainable rebar handle.
- targetsToConstrain IList Reference
- Represent the refernces to be checked as valid targets for handle.
Return Value
Boolean
Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The RebarConstraintsManager does not manage a valid Rebar element. |

For a free form rebar valid targets are one or more references to faces of elements that can host rebar.
For a shape driven rebar this function will always return false. RebarConstraintsManager.GetConstraintCandidatesForHandle() can be used to obtain possible constraints.