Generate a new radial dimension object using a specified dimension type.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- view
- Type: Autodesk.Revit.DBView
The view in which the dimension is to be visible.
- arcRef
- Type: Autodesk.Revit.DBReference
Geometric reference of the arc to which the dimension is to be bound.
- origin
- Type: Autodesk.Revit.DBXYZ
The point where the witness line of the radial dimension will lie.
- dimensionType
- Type: Autodesk.Revit.DBDimensionType
The dimension style to be used for the dimension.
Return Value
If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.Remarks
The dimension will be created on default place.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when any input argument is a null reference (Nothing in Visual Basic). |
Autodesk.Revit.ExceptionsArgumentException | Thrown when the argument arcRef/dimensionType is invalid. |
Autodesk.Revit.ExceptionsInvalidOperationException | Thrown when the creation failed. |