NewRadialDimension Method (View, Reference, XYZ, DimensionType)


Family Item Factory New Radial Dimension(View, Reference, XYZ, Dimension Type) Method

Generate a new radial dimension object using a specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Dimension NewRadialDimension(
	View view,
	Reference arcRef,
	XYZ origin,
	DimensionType dimensionType
)

Parameters

view View
The view in which the dimension is to be visible.
arcRef Reference
Geometric reference of the arc to which the dimension is to be bound.
origin XYZ
The point where the witness line of the radial dimension will lie.
dimensionType DimensionType
The dimension style to be used for the dimension.

Return Value

Dimension
If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception Condition
ArgumentNullException Thrown when any input argument is .
ArgumentException Thrown when the argument arcRef/dimensionType is invalid.
InvalidOperationException Thrown when the creation failed.
Remarks
The dimension will be created on default place.
See Also