IsValidBRepBuilderGeometryIdForNewCorrespondence Method


Validates the input BRepBuilderGeometryId that will be used to create a correspondence. In order to be valid, a correspondence for the input BRepBuilderGeometryId must not already exist.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public bool IsValidBRepBuilderGeometryIdForNewCorrespondence(
	BRepBuilderGeometryId brepBuilderGeometryId
)
Visual Basic
Public Function IsValidBRepBuilderGeometryIdForNewCorrespondence ( _
	brepBuilderGeometryId As BRepBuilderGeometryId _
) As Boolean
Visual C++
public:
bool IsValidBRepBuilderGeometryIdForNewCorrespondence(
	BRepBuilderGeometryId^ brepBuilderGeometryId
)

Parameters

brepBuilderGeometryId
Type: Autodesk.Revit.DBBRepBuilderGeometryId
The BRepBuilderGeometryId to be used in a new correspondence.

Return Value

True if the input BRepBuilderGeometryId can be used to create a new correspondence.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also