BRep |
Validates the input BRepBuilderGeometryId that will be used to create a correspondence. In order to be valid, a correspondence for the input BRepBuilderGeometryId must not already exist.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public bool IsValidBRepBuilderGeometryIdForNewCorrespondence(
BRepBuilderGeometryId brepBuilderGeometryId
)
Parameters
- brepBuilderGeometryId BRepBuilderGeometryId
- The BRepBuilderGeometryId to be used in a new correspondence.
Return Value
BooleanTrue if the input BRepBuilderGeometryId can be used to create a new correspondence.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |