Finds the KeyBasedTreeEntry associated with the given key value.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- key
- Type: SystemString
The specified key value.
Return Value
The KeyBasedTreeEntry corresponds to the given key value.Remarks
If no matching KeyBasedTreeEntry can be found, null will be returned; The given key value cannot be an empty string.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | key is an empty string. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |